Fortran-Lang Discourse became inaccessible on Chromebook

I often use my Asus Chromebook PA201-DS03 to read This is an older Chromebook beyond its AUE date (2020), but it has been working flawlessly (as far as I can tell) on every site that I pull up. I have been using this Chromebook to read this site since I joined, over six months ago.

About a week ago, when I opened in the Chrome browser on this specific Chromebook, I saw a completely blank screen. One by one, I disabled ad blockers and other Chrome extensions to see if I could regain access by doing so. All attempts failed.

Today, I tried again, and this time I could see a garbled presentation of the Fortran-Lang.Discourse.Group page, and a message at the top saying that my browser was out of date. Log-in was disabled.

I accept that the site may wish to shut out people whose browsers are very old, and that Google wants the public to keep buying new Chromebooks every couple of years. Nevertheless, I wanted to bring this issue to your attention.

Hi @mecej4, sorry to hear, that’s annoying. Unfortunately we don’t have control over the technical aspects of Discourse. We’re merely users of the service. Can you post your question at

Shouldn’t it be possible to update your browser?

I’m using Mozilla Firefox (98.0.1) and I’ve had a garbled layout a few times, but it usually fixes itself upon refreshing. Not sure whether to blame my browser, the host servers, or my unstable WiFi connection.

Thanks, I have posted the complaint at

P.S., 10 hours later:

Their response: “We rolled out the fix for that site recently, so users on Chrome < 85 should be able to visit and receive the read-only version of Discourse on that site now.”

1 Like

Chrome OS allows only Chrome as the browser. Every Chromebook is branded with an AUE date, after which it stops receiving updates.

Several weeks later, I found that fortran-lang.discourse works normally again, even though they wrote that they had restored only the read-only mode.

1 Like is down. cannot open the website.

1 Like

I have downloaded the App of it and using it from the Desktop.

Yep, its the same for me I think the host is down? I tried DNS lookup on my system and via an External service and both of them couldn’t resolve it.

@milancurcic you think the VS Code verification might have something to do with this, or is it just bad timing?

1 Like

Thanks for pinging me. It should be up now, it is for me.

This was my blunder–when inserting the TXT record, I somehow managed to wipe the existing A record, which caused to no longer point to our GitHub pages.

1 Like