Server Initialization failure 'UnicodeDecodeError'

I have this kind of problem between ModerFortran and Visual Studio Code.
The extensions worked well but today it does not work and it shows the following error that seems to be related to “UnicodeDecodeError”.

I tried to unistall and install again the extension but the problem remains.
I do not understand how to solve this issue and probably some of you have had the same problem.
I attach the screenshot of the output:

Can you help me?


Welcome to Fortran-lang! Please post

  • a minimal sample of the Fortran file that caused this
  • your Python version
  • the version of fortls
  • the version of Modern Fortran for VS Code
  • the version of VS Code
  • Any Fortran specific VS Code settings

after reinstalling for the second time Modern Fortrna and fortls, this error disappeared (I am sure that I made a mess :-)).

But unfortunately, now it seems that I can not use the Gotos…Peek etc. functions.

I notice that I correctly receive compiler results (I use “ifort”) and I receive correct suggestions if, for example I write “sub” in my code (a subroutine template is suggested). So it seems to me that something works but not completely.

I see that no popup appears during initialization.

Here some info related to my configuration:

1- Python version → Python 3.10.4

2- fortls version → 3.1.2

4- Version of Modern Fortran → v3.4.2024061901 (pre-release)

5 -VS Code Version → 1.90.2

Thanks for your help :slight_smile:


I solved my problem. I accidentally select the option to “disable fortls” :slight_smile: .


Sorry for this…