Need help compiling CALPUFF

I am trying to compile CALPUFF ( on Linux. I have access to GNU, Intel and Portland compilers. I was able to successfully compile its preprocessor (CALMET) and post-processors (CALPOST) using Portland compiler. I attempted compiling the CALPUFF program using the following command:

pgf90 -O0 -Kieee -Msave -Mbackslash -v -pgf90libs -Mpreprocess modules.for calpuff.for -o calpuff.x

The process exited with pgf90-Fatal-/usr/bin/as TERMINATED by signal 11

Any help with the process will be appreciated. TIA

Edit: I am using v7.2.1

For some reason your link did not work for me. Adding http seems to do the trick (

Btw, welcome to Fortran Discourse!

Thank you!

I am using v7.2.1. For reference, when I am compiling it takes 8-12 hours before replying with error.

I tried compiling the code with gfortran 10.2.0 but the code contains a large number of errors of the type rank mismatch. mismatches in types of arguments etc. It looks like it relies on ancient practices :confused:
The good news is: it finished processing the code in less than a minute.
I have not tried to reduce the diagnostics level.

Intel Fortran is quite good for these legacy codes with non-standard practices and indeed the code compiles with Intel Fortran 2021.1.2. I haven’t however tested the executable that was produced.

Using -fallow-argument-mismatch may help with gfortran, but there were a handful of other errors that gfortran still wasn’t happy about.

ifort was quiet robust. I was able to compile using that with optimization level at 0