Modern Fortran Acting Odd

Hey guys, I have had a multitude of issues with the Modern Fortran extension since I installed it. It acts completely bonkers for me. As of 2 months ago, it stopped checking my syntax as I code. It only syntax checks after I save now. And a couple of days ago, I installed fprettify to format my F90 source code, and it worked beautifully. But I tried formatting today, and it just stopped working, and said it’d download findent using pip.

Does anybody face the same issue, or have a fix/alternative for this extension?

Thanks in advance.

Welcome @EthanKletschke to Fortran-lang.

I saw your review on the VS Code store, but I will respond here to keep the conversation in one place.
There haven’t been any changes to the extension in the last 2 months (other than security updates).
It sounds like something changed(or became deprecated) in your system.

Can you please post more details like:

  • OS
  • Extension version
  • Version of VS Code
  • version of Python

and any other information that would make your problem traceable and reproducible.

Hello, @gnikit, thanks for responding. I think the problem is Python, because
I’m on Windows 10, using the release version of the extension (i don’t know the exact version, unfortunately), the latest version of VS Code, but my Python installation has been acting weird for a while now. I’ll try check that and get back to you!

I appreciate the response, and sorry for the one-star review!

Reinstalled Python (3.12.1), and it’s acting fine (pip works fine, etc.), but no luck with Modern Fortran and the formatters…

I’m gonna try turn off all my extensions except Modern Fortran (and whatever other extensions it needs), and see if THAT works.

The version of the extension can be found here (see next to Modern Fortran)

and the version of VS Code can be found in Help>About, mine is:


For the formatters you might need to point directly at the formatter’s .exe, Windows has some issues with auto-detecting Python executables installed via pip since the install location is not in $PATH by default.

I got this for my VS Code,
and my Modern Fortran Version is v3.2.0.

Your formatters should be able to work (assuming they are installed and pointed to in your settings).

@EthanKletschke Could I please ask you, since the problem was external to our extension and related to your Python installation, to edit or delete you Modern Fortran review in the VS Code store.

Yes of course! I’ll do that now!