Fortls real-8 and double-8 in different folders?

(this is my first post in this forum. So a warm …)

Hello there!

… I’m currently trying to (re)setup my Fortran project in VSCode with the ‘Modern Fortran’ extension and ‘Fortls’ for linting. The problem I have is, that my project consists out of real-8 and double-8 modules:

.\src*.f90 → the double-8 modules
.\src\specials*.f → the real-8 modules

The gfortran make job with some specials to handle the two folders runs fine. But the linter is confused :worried:

Is there a way to tell ‘fortls’ in the VSCode settings to use real-8 in the one folder, double-8 for the other main folder?

Best reagrds and thank you!


Welcome! :wave:

How does the linter express its confusion?

Hello and thank you for your question!

… it gave me the hint, that the confusion could probably sit in front of this screen :wink:
So I made fresh start and made it with …

"fortran.linter.extraArgs": [

So easy …The older real-8 modules do have implicit types with ‘I,K,M,N’ (oh, oh - I recalled 40 years ago :grinning: )

Thanks again!