Intel Fortran compiler 2024.0.1

As I wanted to try ifx 2024.0.1, the Intel website said to download but not what to do next. My guess seemed to be wrong. Evidence from my Ubuntu system:

john@johns-laptop:~$ ls -l l_fortran-compiler_p_2024.0.1*
-rw-rw-r-- 1 john john 19788147 Dec 16 19:48
john@johns-laptop:~$ source
bash: source: cannot execute binary file

Same bad result if I tried again after source /opt/intel/oneapi/
What should I have done?

try running the following command: bash, and if necessary, use sudo. I have successfully installed it on my Ubuntu system.

Thank you @Ali but I still can’t compile a program with the latest ifx. Evidence:

john@johns-laptop:~$ cat bin/ifx.1
# compile and run a Fortran program with ifx 2024.0.1
source ~/intel/oneapi/ 
compilers="~/intel/oneapi/compiler/latest" # for ifx, ifort
set -x
$compilers/bin/ifx -standard-semantics -static-intel -L/lib/gcc/x86_64-linux-gnu/13 -limf -lgcc -lgcc_s "$@"
john@johns-laptop:~$ ./bin/ifx.1 hello.f 

:: initializing oneAPI environment ...
  ifx.1: BASH_VERSION = 5.1.16(1)-release
  args: Using "$@" for arguments: hello.f
:: compiler -- latest
:: debugger -- latest
:: mpi -- latest
:: oneAPI environment initialized ::

LD_LIBRARY_PATH is /home/john/intel/oneapi/mpi/2021.11/opt/mpi/libfabric/lib:/home/john/intel/oneapi/mpi/2021.11/lib:/home/john/intel/oneapi/debugger/2024.0/opt/debugger/lib:/home/john/intel/oneapi/compiler/2024.0/opt/compiler/lib:/home/john/intel/oneapi/compiler/2024.0/lib
+ '~/intel/oneapi/compiler/latest/bin/ifx' -standard-semantics -static-intel -L/lib/gcc/x86_64-linux-gnu/13 -limf -lgcc -lgcc_s hello.f
./bin/ifx.1: line 7: ~/intel/oneapi/compiler/latest/bin/ifx: No such file or directory
+ ./a.out
./bin/ifx.1: line 8: ./a.out: No such file or directory
john@johns-laptop:~$ ls -l ~/intel/oneapi/compiler/latest/bin/ifx
-rwxr-xr-x 1 john john 4177208 Nov 22 18:57 /home/john/intel/oneapi/compiler/latest/bin/ifx

What should I do now? I note that installing ifx 2024.0 automatically put the Intel stuff into /opt/intel on Nov 22 but using
put it into ~/intel , and the
~/intel/oneapi/compiler/latest/bin/ifx file was still the Nov 22 one.

During the installation via the GUI, ensure you modify the installation location. The default location is your home directory (~/intel/oneapi), but you have to change it to match the latest installation path. If you previously installed version 2024.0 in the /opt/intel/oneapi directory, make sure to select the same directory (/opt/intel/oneapi) as the installation path for the new update (2024.0.1). you may need to execute the installation using sudo bash

Thank you again @Ali. But when I tried what you suggested , hoping for 2024.0.1, the GUI installation said

Intel(R) Get Started with the Intel(R) Fortran Compiler Classic and Intel(R) 
Fortran Compiler
ID           Date             Version
767720   11/07/2023  2024.0(latest)

which made me suspect I was going to get 2024.0 again.

When I execute sudo bash for the installation, this is the output I receive:

If you want to modify the installation directory, you can adjust it at this stage. In my case, I changed the installation location to match the previous version:

I’m not sure why it shows 2024.0 for you. Maybe this version is an update from the earlier one, 2024.0. The new version 2024.0.1 might need the 2024.0 version to work properly. But I’m just guessing!

Once the installation is complete, go to this directory to check for the new compiler:
Then, execute:
./ifx --version
This should output:

ifx (IFX) 2024.0.1 20231122
Copyright (C) 1985-2023 Intel Corporation. All rights reserved.