Fpm fails silently on Windows

I have been exploited fpm successfully on Mac with gfortran. Now I tried to switch to Windows and got a weird behavior.

fpm fails in terminal (I tried CommandPrompt and Git Bash) with no error. For example:
(venv) C:\Users\mrazu\venv\Scripts>fpm -- help

(venv) C:\Users\mrazu\venv\Scripts>fpm.exe

(venv) C:\Users\mrazu\venv\Scripts>

** no error in the output **

I have installed it by means of pip. I also have mingw64 installed and I double checked that mingw64/bin and fpm are in the PATH. I use x64 architecture. Compiling and running Fortran code with gfortran from terminal is OK.

Please suggest, how to troubleshoot it and make fpm running.

Thanks in advance !

Sounds like a lack of link library dependency? If fpm is in the environment path and there is no feedback when running, it may be that the runtime dependency .dll needed by fpm is not found.

Try using ldd fpm.exe to check the dependencies?

Here are the dependencies and likely paths to these libs on my OS:

$ ldd fpm.exe        
ntdll.dll => /c/Windows/SYSTEM32/ntdll.dll (0x7ffb5f550000)
KERNEL32.DLL => /c/Windows/System32/KERNEL32.DLL (0x7ffb5f2b0000)        
KERNELBASE.dll => /c/Windows/System32/KERNELBASE.dll (0x7ffb5cdd0000)
SHLWAPI.dll => /c/Windows/System32/SHLWAPI.dll (0x7ffb5e350000)        
msvcrt.dll => /c/Windows/System32/msvcrt.dll (0x7ffb5d810000)

It does not seems like an error, right ?

1 Like